Have a Juniper Oliver running in my vm environment as a test for a while.
I believe it is common for people like to research network technology but would not like to purchase expansive devices to stack them at home. To make myself more understanding how ospf operate in JunOS environment, I started to set up a small topology to configure OSPF with logical router feature.
I believe it is common for people like to research network technology but would not like to purchase expansive devices to stack them at home. To make myself more understanding how ospf operate in JunOS environment, I started to set up a small topology to configure OSPF with logical router feature.
So far, only configured OSPF area 10 between logical router R1 and R2:
root> show configuration
## Last commit: 2012-01-23 02:18:33 UTC by root
version 10.4R3.4;
system {
root-authentication {
encrypted-password "$1$tD7scqlb$0OSEHovD6G2Oez087zChZ/"; ## SECRET-DATA
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
logical-systems {
r1 {
interfaces {
em1 {
unit 12 {
vlan-id 12;
family inet {
address 10.1.12.1/24;
}
}
unit 13 {
vlan-id 13;
family inet {
address 10.1.13.1/24;
}
}
unit 14 {
vlan-id 14;
family inet {
address 10.1.14.1/24;
}
}
}
lo0 {
unit 1 {
family inet {
address 10.1.1.1/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.10 {
interface em1.12;
interface lo0.1;
}
}
}
}
r2 {
interfaces {
em2 {
unit 12 {
vlan-id 12;
family inet {
address 10.1.12.2/24;
}
}
}
lo0 {
unit 2 {
family inet {
address 10.1.1.2/32;
}
}
}
}
protocols {
ospf {
area 0.0.0.10 {
interface lo0.2;
interface em2.12;
}
}
}
}
}
interfaces {
em0 {
unit 0 {
family inet {
address 192.168.2.230/24;
}
}
}
em1 {
vlan-tagging;
}
em2 {
vlan-tagging;
}
}
root>
test> show ospf neighbor logical-system r1
Address Interface State ID Pri Dead
10.1.12.2 em1.12 Full 10.1.1.2 128 33
test> show ospf da logical-system r1
OSPF database, Area 0.0.0.10
Type ID Adv Rtr Seq Age Opt Cksum Len
Router *10.1.1.1 10.1.1.1 0x80000071 2145 0x22 0x5901 48
Router 10.1.1.2 10.1.1.2 0x8000006d 2146 0x22 0x75e4 48
Network 10.1.12.2 10.1.1.2 0x80000040 2146 0x22 0x8533 32
No comments:
Post a Comment